Cannot install old MacOS from App Store for running 32 bit apps

I want to install an older macOS version in a virtual machine (using Parallels) to run old 32 bit apps. I try to download using this page: https://support.apple.com/en-gb/HT211683 I tried to download High Sierra 10.13 from the it's App Store page. I've read this should lead to a "Install macOS ..." app file which can be used by Parallels Desktop. But whenever I click "Get" on it opens "Software Update" page of System Preferences app For even older macOS versions, there are links to download a DMG. I've downloaded a DMG of Sierra 10.12 with InstallOS.pkg in it. However, running PKG only shows the message "unable to install" (probably because I have 11.2 Big Sur). Both these DMG and PKG aren't suitable for Parallels as an image file. How can I get a normal image of MacOS

Cannot install old MacOS from App Store for running 32 bit apps

I want to install an older macOS version in a virtual machine (using Parallels) to run old 32 bit apps. I try to download using this page: https://support.apple.com/en-gb/HT211683

I tried to download High Sierra 10.13 from the it's App Store page. I've read this should lead to a "Install macOS ..." app file which can be used by Parallels Desktop. But whenever I click "Get" on it opens "Software Update" page of System Preferences app

For even older macOS versions, there are links to download a DMG. I've downloaded a DMG of Sierra 10.12 with InstallOS.pkg in it. However, running PKG only shows the message "unable to install" (probably because I have 11.2 Big Sur). Both these DMG and PKG aren't suitable for Parallels as an image file.

How can I get a normal image of MacOS <= 10.14?